1000: A+B Problem
Description
Calculate a+b
Input
Two integer a,b (0<=a,b<=10)
Output
Output a+b
Sample Input Copy
1 2
Sample Output Copy
3
HINT
常见错误解答:
#include <iostream>
using namespace std ; /* 上面两行不能改成 #include <iostream.h> */
void main() /* 此处错误,main函数返回值必须是int,否则会编译错误 */
{
int a,b;
cout<<"Please input number a,b : "<<endl; /*此处
错误,请一定注意题目要求,题目要求输出“两个整数的和”,所以只需输出一个整数即可,任何超出题目要求的输出(即使只是打印一行提示)都会导致 Wrong Answer ,因为系统是基于答案的完全匹配来评判的。*/
cin>>a>>b;
cout<<"a+b="<<a+b<<endl; /* "a+b="这一句是多余的,也是错误的,理由同上。*/
}
如果对程序答题格式不清楚的,可以查看系统左上角菜单的FAQ,里面有本题的各种语言的样例解答。在此列出用C/C++语言的答题示例如下(请把下面代码拷贝到代码提交框,点击提交):
请注意代码中红颜色的部分,该部分与常用的VC编译器不同
C语言(使用GCC编译器):
#include <stdio.h>
int main()
{
int a,b;
scanf("%d %d",&a, &b);
printf("%d\n",a+b);
return 0;
}
C++语言(使用G++编译器):
使用新的ANSI标准库,注意头文件的写法和using namespace std 这句。
#include <iostream>
using namespace std;
int main()
{
int a,b;
cin >> a >> b;
cout << a+b << endl;
return 0;
}
另附:
注意:如果选择Java编译,类名要为Main,代码见下面。Java编译器为JDK 1.6。
A: Your program shall always read input from stdin (Standard Input) and write output to stdout (Standard Output). For example, you can use 'scanf' in C or 'cin' in C++ to read from stdin, and use 'printf' in C or 'cout' in C++ to write to stdout.
You shall not output any extra data to standard output other than that required by the problem, otherwise you will get a "Wrong Answer".
User programs are not allowed to open and read from/write to files. You will get a "Runtime Error" or a "Wrong Answer"if you try to do so.
Here is a sample solution to problem 1000 using C++/G++:
#include <iostream>It's important that the return type of main() must be int when you use G++/GCC,or you may get compile error.
using namespace std;
int main()
{
int a,b;
cin >> a >> b;
cout << a+b << endl;
return 0;
}
Here is a sample solution to problem 1000 using C/GCC:
#include <stdio.h>Here is a sample solution to problem 1000 using Pascal:
int main()
{
int a,b;
scanf("%d %d",&a, &b);
printf("%d\n",a+b);
return 0;
}
program p1000(Input,Output);Here is a sample solution to problem 1000 using Java:
var
a,b:Integer;
begin
Readln(a,b);
Writeln(a+b);
end.
Now java compiler is jdk 1.5, next is program for 1000
import java.io.*;Old program for jdk 1.4
import java.util.*;
public class Main
{
public static void main(String args[]) throws Exception
{
Scanner cin=new Scanner(System.in);
int a=cin.nextInt(),b=cin.nextInt();
System.out.println(a+b);
}
}
import java.io.*;Here is a sample solution to problem 1000 using Fortran:
import java.util.*;
public class Main
{
public static void main (String args[]) throws Exception
{
BufferedReader stdin =
new BufferedReader(
new InputStreamReader(System.in));
String line = stdin.readLine();
StringTokenizer st = new StringTokenizer(line);
int a = Integer.parseInt(st.nextToken());
int b = Integer.parseInt(st.nextToken());
System.out.println(a+b);
}
}
PROGRAM P1000
IMPLICIT NONE
INTEGER :: A, B
READ(*,*) A, B
WRITE(*, "(I0)") A + B
END PROGRAM P1000